vCenter Infrastructure Navigator – Error Retrieving Data

It’s been quite frequent that I’ve encountered the error in vCenter Infrastructure Navigator (VIN) at my home lab so I thought I will post some screenshots on this and some screenshots of how the resolution of this problem with reference to the KB as below.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2044117

In general, the steps are simple. It’s simply unbinding the vServices from VIN from vServices and binding it again. See below for errors and step by step guide.

Errors Screenshots that you are likely to face when you have this error:

vin-01 vin-02 vin-03Resolution as per KB. See Screenshots below:

  • Shutdown your vCenter Infrastructure Navigator Virtual Appliance and right-click on your VM, choose Edit Settings. Choose vServices┬átab and you should see the screen below.
    vin-04
  • Click Edit button at the binding section
    vin-05
  • Under Provider drop-down menu, choose <No Provider>. Click OK
    vin-06
  • You should see the state of your extension service to Changing. Click OK again.
    vin-07
  • Right-click on your VM and choose Edit Settings again and go to vServices tab. You should see the state of your extension services “Unbound
    vin-08
  • Again click Edit at the binding section and choose Provider as “vCenter Extension Servicevin-09
  • Click OK and you should be done. Power up your VIN VM and your application dependencies service should be up again.vin-10vin-11

2 Comments

  1. Tracy Watson July 30, 2014 5:20 am  Reply

    this worked perfectly! Thank you so much.

  2. Sean McCann February 11, 2015 4:36 am  Reply

    I am wondering why VIN seems to become unbound after a while. I have used this fix several times and then say a month later, I get the same error “Error while retrieving data..”

Leave a Reply

* Copy This Password *

* Type Or Paste Password Here *

21,160 Spam Comments Blocked so far by Spam Free Wordpress